$re = '/^\d$/m';
$str = '0
1
3
9
10
11
12
';
$subst = "0\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;