import re
regex = re.compile(r"^\d$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"3\n"
"9\n"
"10\n"
"11\n"
"12\n")
subst = "0\\0"
result = regex.sub(subst, test_str)
if result:
print(result)