#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(['"])(?:(?!\1|\\).|\\.)*\1|\/\/[^\n]*(?:\n|$)|\/\*(?:[^*]|\*(?!\/))*\*\/)(*SKIP)(*FAIL)|\^"
Local $sString = "/* some commented code " & @CRLF & _
"^ with ^ xors */" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"'asdfasdf'; 'asdfasd'^'asdflkj';" & @CRLF & _
"['asdf', '^', 'asdf'];" & @CRLF & _
"" & @CRLF & _
"// more commented code ^ with ^ xors" & @CRLF & _
"" & @CRLF & _
" 'asdf1524-sdfaA'^'sdfa322='" & @CRLF & _
" 'sdfa22_'^$myvar" & @CRLF & _
" $myvar^'asAf34%'" & @CRLF & _
"" & @CRLF & _
" ['+','*','^','%']" & @CRLF & _
" '^'=>2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")