$re = '/(?:([\'"])(?:(?!\1|\\\\).|\\\\.)*\1|\/\/[^\n]*(?:\n|$)|\/\*(?:[^*]|\*(?!\/))*\*\/)(*SKIP)(*FAIL)|\^/';
$str = '/* some commented code
^ with ^ xors */
\'asdfasdf\'; \'asdfasd\'^\'asdflkj\';
[\'asdf\', \'^\', \'asdf\'];
// more commented code ^ with ^ xors
\'asdf1524-sdfaA\'^\'sdfa322=\'
\'sdfa22_\'^$myvar
$myvar^\'asAf34%\'
[\'+\',\'*\',\'^\',\'%\']
\'^\'=>2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);