re = /(?:(['"])(?:(?!\1|\\).|\\.)*\1|\/\/[^\n]*(?:\n|$)|\/\*(?:[^*]|\*(?!\/))*\*\/)(*SKIP)(*FAIL)|\^/
str = '/* some commented code
^ with ^ xors */
\'asdfasdf\'; \'asdfasd\'^\'asdflkj\';
[\'asdf\', \'^\', \'asdf\'];
// more commented code ^ with ^ xors
\'asdf1524-sdfaA\'^\'sdfa322=\'
\'sdfa22_\'^$myvar
$myvar^\'asAf34%\'
[\'+\',\'*\',\'^\',\'%\']
\'^\'=>2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end