using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(.+) )?love(?: (.+))?!";
string input = @"- Valid matches:
love!
9 love!
love Caffè!
i love you!
- Invalid matches:
love
iloveyou";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}