re = /(?:(.+) )?love(?: (.+))?!/
str = '- Valid matches:
love!
9 love!
love Caffè!
i love you!
- Invalid matches:
love
iloveyou'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end