$re = '/(?:(.+) )?love(?: (.+))?!/';
$str = '- Valid matches:
love!
9 love!
love Caffè!
i love you!
- Invalid matches:
love
iloveyou';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);