$re = '/(?<!\d)123(?!\d)/';
$str = '123 asdf123x 99 123
won\'t match
0123 1234 123123 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);