import re
regex = re.compile(r"(?<!\d)123(?!\d)")
test_str = ("123 asdf123x 99 123\n\n"
"won't match \n"
"0123 1234 123123 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")