re = /(?<!\d)123(?!\d)/
str = '123 asdf123x 99 123
won\'t match
0123 1234 123123 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end