#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(#Macro(.|[\r\n])+?#EndMacro)"
Local $sString = " #Macro" & @CRLF & _
" #object" & @CRLF & _
" value=1" & @CRLF & _
" value=2" & @CRLF & _
" #EndMacroEnt" & @CRLF & _
" #object" & @CRLF & _
" value=5" & @CRLF & _
" value=6" & @CRLF & _
" #EndMacroEnt" & @CRLF & _
" #EndMacro"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")