re = /(#Macro(.|[\r\n])+?#EndMacro)/
str = ' #Macro
#object
value=1
value=2
#EndMacroEnt
#object
value=5
value=6
#EndMacroEnt
#EndMacro'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end