#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(([a-zA-Z]*)(\.[a-zA-Z\?\=\&]*))?$"
Local $sString = "DO MATCH:" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"/index.htm" & @CRLF & _
"/cat.gif" & @CRLF & _
"/process.php?help=me&support=you" & @CRLF & _
"" & @CRLF & _
"DO NOT MATCH:" & @CRLF & _
"" & @CRLF & _
"/test/notcatch" & @CRLF & _
"/myfile" & @CRLF & _
"/process?help=me&support=you" & @CRLF & _
"/test/notcatch.me" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")