using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/(([a-zA-Z]*)(\.[a-zA-Z\?\=\&]*))?$";
string input = @"DO MATCH:
/
/index.htm
/cat.gif
/process.php?help=me&support=you
DO NOT MATCH:
/test/notcatch
/myfile
/process?help=me&support=you
/test/notcatch.me
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}