package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(([a-zA-Z]*)(\.[a-zA-Z\?\=\&]*))?$`)
var str = `DO MATCH:
/
/index.htm
/cat.gif
/process.php?help=me&support=you
DO NOT MATCH:
/test/notcatch
/myfile
/process?help=me&support=you
/test/notcatch.me
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}