#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:\.)(VFI?|FR|ENGLISH|EN|SPANISH|SPA)(?:\.|$)"
Local $sString = "Virgin..Suicides..vfi..vf..1999..1080p..FR..EN..X264..AC3-mHDgz-www..Zone-Telechargement..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")