using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.)(VFI?|FR|ENGLISH|EN|SPANISH|SPA)(?:\.|$)";
string input = @"Virgin..Suicides..vfi..vf..1999..1080p..FR..EN..X264..AC3-mHDgz-www..Zone-Telechargement..com";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}