using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9\-\.]{1,2})([0-9\-\.]{1,2}){5}$";
string input = @"06-61.27-14.23";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}