$re = '/([0-9\-\.]{1,2})([0-9\-\.]{1,2}){5}$/';
$str = '06-61.27-14.23';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);