using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\,\-?!*½=+$#£(){} % ]+";
string substitution = @"";
string input = @"Allahümmerzuknaâ kalben takiyyen mineşşirki
beriyyen la kafiren ve la @£$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !""#¤%&'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}