const regex = /[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\,\-?!*½=+$#£(){} % ]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9ğüşıöçĞÜŞİÖÇ?!.;\\\\,\\-?!*½=+$#£(){} % ]+', '')
const str = `Allahümmerzuknaâ kalben takiyyen mineşşirki
beriyyen la kafiren ve la @£\$¥èéùìòÇ Øø ÅåΔ_ΦΓΛΩΠΨΣΘΞ€ÆæßÉ !"#¤%&'()*+,-./:;<=>?¡ÄÖÑܧ¿äöñüà `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);