using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=\d{1,2}:\d{1,2})";
string substitution = @"\n";
string input = @"46:28 Corner, Switzerland. Conceded by Walter AyovÃ. 46:26 Attempt blocked. Stephan Lichtsteiner (Switzerland) left footed shot from outside the box is blocked. Assisted by Granit Xhaka. 45:00][Second Half begins Switzerland 0, Ecuador 1. 45:00 Substitution]
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}