re = / (?=\d{1,2}:\d{1,2})/m
str = '46:28 Corner, Switzerland. Conceded by Walter AyovÃ. 46:26 Attempt blocked. Stephan Lichtsteiner (Switzerland) left footed shot from outside the box is blocked. Assisted by Granit Xhaka. 45:00][Second Half begins Switzerland 0, Ecuador 1. 45:00 Substitution]
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result