use strict;
my $str = '46:28 Corner, Switzerland. Conceded by Walter AyovÃ. 46:26 Attempt blocked. Stephan Lichtsteiner (Switzerland) left footed shot from outside the box is blocked. Assisted by Granit Xhaka. 45:00][Second Half begins Switzerland 0, Ecuador 1. 45:00 Substitution]
';
my $regex = qr/ (?=\d{1,2}:\d{1,2})/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";