#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^)"(?!$)"
Local $sString = "Here is each field of interest as it goes through step 1 and 2 of the loop:" & @CRLF & _
"" & @CRLF & _
"field" & @CRLF & _
"field" & @CRLF & _
"" & @CRLF & _
"another "field"" & @CRLF & _
""another "field""" & @CRLF & _
"" & @CRLF & _
""another" field" & @CRLF & _
"""another" field"" & @CRLF & _
"" & @CRLF & _
""fie|ld"" & @CRLF & _
""fie|ld""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")