import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^)\"(?!$)";
final String string = "Here is each field of interest as it goes through step 1 and 2 of the loop:\n\n"
+ "field\n"
+ "field\n\n"
+ "another \"field\"\n"
+ "\"another \"field\"\"\n\n"
+ "\"another\" field\n"
+ "\"\"another\" field\"\n\n"
+ "\"fie|ld\"\n"
+ "\"fie|ld\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}