$re = '/(?<!^)"(?!$)/m';
$str = 'Here is each field of interest as it goes through step 1 and 2 of the loop:
field
field
another "field"
"another "field""
"another" field
""another" field"
"fie|ld"
"fie|ld"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);