package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<!--.*>([\s\S]*)<!\[endif\]-->`)
var str = `<!--[if !mso]>
<style>
v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style>
<![endif]-->`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}