import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--.*>([\\s\\S]*)<!\\[endif\\]-->";
final String string = "<!--[if !mso]>\n"
+ "<style>\n"
+ "v\\:* {behavior:url(#default#VML);}\n"
+ "o\\:* {behavior:url(#default#VML);}\n"
+ "w\\:* {behavior:url(#default#VML);}\n"
+ ".shape {behavior:url(#default#VML);}\n"
+ "</style>\n"
+ "<![endif]-->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}