# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--.*>([\s\S]*)<!\[endif\]-->"
test_str = ("<!--[if !mso]>\n"
"<style>\n"
"v\\:* {behavior:url(#default#VML);}\n"
"o\\:* {behavior:url(#default#VML);}\n"
"w\\:* {behavior:url(#default#VML);}\n"
".shape {behavior:url(#default#VML);}\n"
"</style>\n"
"<![endif]-->")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.