const regex = /(?<=figcaption)(?:.*?(#\w+)+)+?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=figcaption)(?:.*?(#\\w+)+)+?', 'g')
const str = `<figcaption>blah blah #hashtag1, #hashtag2</figcaption>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}