re = /(?<=figcaption)(?:.*?(#\w+)+)+?/
str = '<figcaption>blah blah #hashtag1, #hashtag2</figcaption>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end