$re = '/(?<=figcaption)(?:.*?(#\w+)+)+?/';
$str = '<figcaption>blah blah #hashtag1, #hashtag2</figcaption>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);