#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\d.]+)\s+PER\s+(.*?)(?:\sIn\s*(.+?))?(?:\s*DEAD.*)?$"
Local $sString = "1.0 PER Sample DEAD VOLUME 1" & @CRLF & _
"1.0 PER Request DEAD VOLUME 1" & @CRLF & _
"10.0 PER Empty Well In Column DEAD VOLUME 10" & @CRLF & _
"8.0 PER Empty Well In Row DEAD VOLUME 8" & @CRLF & _
"1.0 PER Sample" & @CRLF & _
"1.0 PER Request" & @CRLF & _
"10.0 PER Empty Well In Column"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")