# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\d.]+)\s+PER\s+(.*?)(?:\sIn\s*(.+?))?(?:\s*DEAD.*)?$"
test_str = ("1.0 PER Sample DEAD VOLUME 1\n"
"1.0 PER Request DEAD VOLUME 1\n"
"10.0 PER Empty Well In Column DEAD VOLUME 10\n"
"8.0 PER Empty Well In Row DEAD VOLUME 8\n"
"1.0 PER Sample\n"
"1.0 PER Request\n"
"10.0 PER Empty Well In Column")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.