re = /(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)/
str = '123
9876456000
123456789
91370
111
415263
xyz123xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end