import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\w]+";
final String string = "зеркало5. \n"
+ "⊕57,371. \n"
+ "623'`224↓57,3. \n"
+ "60↑57,37209. \n"
+ "OUskjh(*&^0238764 _-~`,./][';";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}