using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\s*!\s+\[(?:remote )?rejected].+\((?:non-fast-forward|fetch first|cannot lock ref.*)\)\s*$";
string input = @" ! [rejected] krancour/foo -> krancour/foo (non-fast-forward)
! [rejected] main -> main (fetch first)
! [remote rejected] HEAD -> experiment (cannot lock ref 'refs/heads/experiment': is at 7dc98ee9c0b75be429e300bb59b3cf6d091ca9ed but expected 1bdf96c8c868981a0e24c43c98aef09a8970a1b8)
! [rejected] HEAD -> experiment (fetch first)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}