const regex = new RegExp('(?m)^\\s*!\\s+\\[(?:remote )?rejected].+\\((?:non-fast-forward|fetch first|cannot lock ref.*)\\)\\s*$', 'g')
const str = ` ! [rejected] krancour/foo -> krancour/foo (non-fast-forward)
! [rejected] main -> main (fetch first)
! [remote rejected] HEAD -> experiment (cannot lock ref 'refs/heads/experiment': is at 7dc98ee9c0b75be429e300bb59b3cf6d091ca9ed but expected 1bdf96c8c868981a0e24c43c98aef09a8970a1b8)
! [rejected] HEAD -> experiment (fetch first)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}