$re = '`(?m)^\s*!\s+\[(?:remote )?rejected].+\((?:non-fast-forward|fetch first|cannot lock ref.*)\)\s*$`';
$str = ' ! [rejected] krancour/foo -> krancour/foo (non-fast-forward)
! [rejected] main -> main (fetch first)
! [remote rejected] HEAD -> experiment (cannot lock ref \'refs/heads/experiment\': is at 7dc98ee9c0b75be429e300bb59b3cf6d091ca9ed but expected 1bdf96c8c868981a0e24c43c98aef09a8970a1b8)
! [rejected] HEAD -> experiment (fetch first)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);