using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":([^:]*)\.{3}";
string input = @"wqedfw:qwedweqwrrrrrrr...456...365356";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}