package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:([^:]*)\.{3}`)
var str = `wqedfw:qwedweqwrrrrrrr...456...365356`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}