$re = '/("home":\[)(?:(].*)(.{4})$|([^]]+)(.*)(.{5}$))|.{5}$/';
$str = '{"home":["1","2","5"], "work":["15","16","19"]},"11"';
$subst = "\1\3\4\2\6\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;