import Foundation
let pattern = #"("home":\[)(?:(].*)(.{4})$|([^]]+)(.*)(.{5}$))|.{5}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"home":["1","2","5"], "work":["15","16","19"]},"11""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3\4\2\6\5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)