// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("home":\[)(?:(].*)(.{4})$|([^]]+)(.*)(.{5}$))|.{5}$"#).unwrap();
let string = "{\"home\":[\"1\",\"2\",\"5\"], \"work\":[\"15\",\"16\",\"19\"]},\"11\"";
let substitution = "\\1\\3\\4\\2\\6\\5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}