// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<func>\S*)\((?#beginn Param)(.*[,\)])(?#end Param)\)").unwrap();
let string = "KTOVGL('SVVOR', 0, >)
KTOVGL('SVUEB', 0, <)
KTOGR('SVVOR')
KTOGR('SVVOR', 'SVVOR2', 'SVVOR3')
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}