import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d+\\.){3}\\d+)\\h+((?:[[:xdigit:]]{2}-){5}[[:xdigit:]]{2})\\h+(\\V+)";
final String string = "192.168.150.255 ff-ff-ff-ff-ff-ff static\n"
+ "192.168.150.254 e0-cc-56-55-32-21 dynamic\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}