const regex = /((?:\d+\.){3}\d+)\h+((?:[[:xdigit:]]{2}-){5}[[:xdigit:]]{2})\h+(\V+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\d+\\.){3}\\d+)\\h+((?:[[:xdigit:]]{2}-){5}[[:xdigit:]]{2})\\h+(\\V+)', 'g')
const str = `192.168.150.255 ff-ff-ff-ff-ff-ff static
192.168.150.254 e0-cc-56-55-32-21 dynamic
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}