$re = '/((?:\d+\.){3}\d+)\h+((?:[[:xdigit:]]{2}-){5}[[:xdigit:]]{2})\h+(\V+)/';
$str = '192.168.150.255 ff-ff-ff-ff-ff-ff static
192.168.150.254 e0-cc-56-55-32-21 dynamic
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);